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SESSION 1 - CLASS NOTES 

Excel Essentials: Diagnose, Clean and Summarise Data the Professional Way 

These notes cover the eight topics demonstrated in Session 1. Each topic follows the same sequence: 

what the feature is, why it matters in professional and audit work, how to perform it step by step, a 

worked example, and a takeaway. The topics themselves are arranged in the order of a real workflow: 

first diagnose the data, then repair it, then verify it, then summarise it. Practise each one on your own 

files before Session 2, because Session 2 (Advanced Excel) assumes all eight are second nature. 

 

1.  Go To Special (F5) - The Auditor's X-Ray 

What it is 

Press F5 (or Ctrl+G), then click the Special button. Excel then selects, in one action, every cell of a 

particular kind inside your selection: all constants, all formulas, all cells with errors, all blanks, and 

more. Under Constants and Formulas you can further restrict the selection to Numbers, Text, Logicals 

or Errors. 

Why it is an audit tool 

Large imported data hides problems that the eye cannot see: numbers that are actually text, blank 

cells in the middle of a ledger, error values buried in row 1,347, or a hardcoded number typed over a 

formula in someone else's model. Go To Special finds every instance in seconds and, importantly, 

selects them all at once, so you can format, correct or delete them in a single action instead of hunting 

row by row. 

How to do it 

1. Select the data range (or one cell inside it, or entire columns). 

2. Press F5, then click Special (or Home > Find & Select > Go To Special). 

3. Choose the category: Constants > tick only Text (to find text-numbers), or Formulas > tick only 
Errors, or Blanks. 

4. Click OK. Every matching cell is now selected simultaneously - apply a fill colour to mark them, or 
fix them in one go. 

Worked example 

A Trial Balance of 1,500 rows is pasted from the accounting software. Your SUM at the bottom does 

not match the software's total. Select the amount column, press F5 > Special > Constants, untick 

everything except Text, click OK. Fourteen cells light up: these are amounts stored as text, invisible to 

SUM. You have found the entire difference in under ten seconds. A second audit use: select a 

schedule that should be all formulas, choose Formulas first and then Constants - any constant found 

inside a formula area is a manual override someone typed over a calculation. 

Takeaway:  Before analysing any imported data, run F5 > Special as a diagnostic. It converts an 
invisible data problem into a visible, selected, fixable one. 
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2.  Merged Cells - Why They Are Dangerous 

What really happens when you merge 

When cells A5:A9 are merged, the value lives only in the first (top-left) cell, A5. Cells A6 to A9 are 

genuinely empty - they merely display A5's value across their combined area. The data looks complete 

to the eye, but to every formula, four of the five cells are blank. 

Why an auditor must care 

SUMIF, COUNTIF and VLOOKUP read the real cell contents, not the displayed appearance, so a 

merged label is counted once instead of five times and totals silently go wrong. Sorting and filtering are 

often blocked outright with the message that the operation requires merged cells to be identically 

sized. Copy-paste from merged areas misaligns. A report full of merged cells is a report whose 

numbers cannot be safely re-computed - which is exactly the kind of file an auditor receives from a 

client. 

How to find every merged cell in a sheet 

1. Press Ctrl+F to open Find and Replace, and click Options to expand it. 

2. Click Format, go to the Alignment tab, tick Merge cells, click OK. 

3. Leave the 'Find what' box empty and click Find All. 

4. In the results list press Ctrl+A - every merged cell in the sheet is now selected together. 

5. With all of them selected, click Home > Merge & Center once to unmerge them all, then fill the 
resulting blanks (F5 > Special > Blanks, type =A5 style formula referring to the cell above, press 
Ctrl+Enter). 

Worked example 

A client sends a department-wise expense sheet where each department name is merged across its 

five expense rows. Your SUMIF by department returns only the first row's amount per department - 

understating each department by four rows. Using Ctrl+F with the merge format, you locate all 12 

merged blocks at once, unmerge them, fill the blanks downward, and the SUMIF instantly reconciles. 

If a layout genuinely needs a heading spread across columns, use Format Cells > Alignment > 

Horizontal > Center Across Selection instead - it gives the same look with no merging and no 

damage to formulas. 

Takeaway:  Merged cells sacrifice data integrity for appearance. Find them with Ctrl+F > Format > 
Merge cells > Find All, unmerge, and use Center Across Selection when you only need the look. 
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3.  Paste Special > Operations - Transform Without Formulas 

What it is 

Paste Special can do arithmetic while pasting. Copy a single number, select a range, and choose Add, 

Subtract, Multiply or Divide: Excel applies that operation to every selected cell, in place, with no helper 

column and no formula. 

How to do it - flipping signs 

1. Type -1 in any spare cell and copy it (Ctrl+C). 

2. Select all the cells whose sign you want to change. 

3. Press Ctrl+Alt+V (Paste Special), choose the operation Multiply, and - to protect your formatting - 
also tick Values. 

4. Click OK, then delete the helper cell. Every positive is now negative, and every negative is now 
positive. 

The unit-conversion trick 

The same technique converts an entire statement into lakhs or crores: type 100000 (for lakhs) or 

10000000 (for crores) in a spare cell, copy it, select the amounts, and Paste Special > Divide. The 

values themselves change, so use this on a working copy; if you want the display to change while the 

true values stay intact, that is the job of a custom number format instead - a distinction worth 

remembering. 

Worked example 

An exported expense ledger shows all amounts as positive, but your combined receipts-and-payments 

working needs payments as negatives. Rather than building a helper column of =A2*-1, copying, and 

pasting values back - four steps and a broken layout - you copy a single -1 cell and Paste Special > 

Multiply over the payments column. Two thousand cells flip in one action, and the original layout, 

comments and column order are untouched. 

Takeaway:  Copy a number, Paste Special with an Operation, and you have transformed thousands 
of cells in place - no formulas, no helper columns, no re-pasting. 
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4.  TRIM(), CLEAN(), SUBSTITUTE() - Invisible Character Control 

The problem 

Data from ERPs, Tally, websites and PDFs arrives contaminated with characters you cannot see: 

extra spaces before or after text, line breaks and other non-printing characters, and the notorious non-

breaking space that comes from web pages and SAP exports. To your eye, 'Rent ' and 'Rent' are 

identical; to VLOOKUP they are two different values, and the lookup fails. 

The three cleaners and their exact jobs 

Function What it removes What it misses 

TRIM(text) Leading spaces, trailing spaces, and 
collapses repeated internal spaces to 
single spaces 

Non-printing characters; non-
breaking spaces 

CLEAN(text) Non-printing characters (codes 0-31): 
line breaks, tabs and similar imported 
junk 

Ordinary spaces; non-
breaking spaces 

SUBSTITUTE(text, 
CHAR(160), " ") 

The non-breaking space (character 160) 
by replacing it with a normal space 

Everything else - it replaces 
only what you tell it to 

 

Because each one has a blind spot, professionals chain all three into a single master formula: 

=TRIM(CLEAN(SUBSTITUTE(A2, CHAR(160), " "))) 

How to diagnose before you clean 

The test is LEN(). If a ledger name that reads as four characters returns =LEN(A2) of 6, two invisible 

characters are hiding inside. Compare LEN of the raw cell against LEN of the cleaned cell: the 

difference is the number of invisible characters removed. 

Worked example 

A VLOOKUP against the client's ledger master returns errors for three ledgers that visibly exist in both 

lists. LEN() shows the imported names are two characters longer than the master's. Applying the 

master cleaning formula in a helper column brings the lengths into agreement, the lookups resolve, 

and the reconciliation completes - without retyping a single name. 

Takeaway:  When two values look identical but formulas disagree, suspect invisible characters. 
LEN() is the test; TRIM + CLEAN + SUBSTITUTE(CHAR(160)) is the cure. 
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5.  Converting Text-Numbers to Real Numbers 

Recognising the disease 

Numbers stored as text usually align to the left, may show a green triangle in the corner, and are 

ignored by SUM, SUMIF and PivotTables - which is why an imported column can show a total of zero. 

Confirm with =ISTEXT(A2), which returns TRUE for the impostors. 

Cure 1 - NUMBERVALUE() 

NUMBERVALUE converts a text-number to a real number, and its optional arguments let you declare 

which characters the text uses as decimal and group separators - which matters when data comes 

from systems using European formats. 

=NUMBERVALUE("1,25,000")          returns 125000 

=NUMBERVALUE("1.234,56", ",", ".")  returns 1234.56  (European format) 

Cure 2 - arithmetic coercion 

Any arithmetic operation forces Excel to convert text to a number before calculating. Multiplying by 1, 

adding 0, or the double negative all work; this is why a text-number sitting inside a formula like =A2*1 

suddenly behaves. It is a useful trick inside larger formulas where you cannot pre-clean the data. 

=A2*1        =A2+0        =--A2 

Cure 3 - Text to Columns in three clicks (the bulk fix) 

1. Select the entire problem column (one column at a time). 

2. Data > Text to Columns. 

3. Click Next, click Next, click Finish - changing nothing at any step. 

4. Excel re-enters every cell in the column, converting all text-numbers to real numbers in one pass. 

Worked example 

An imported receivables column of 1,500 rows totals zero. ISTEXT confirms the entire column is text. 

Rather than writing a helper column of NUMBERVALUE and pasting values back, you select the 

column and run Text to Columns > Next > Next > Finish. Three clicks, 1,500 conversions, and the 

SUM springs to life. 

Takeaway:  One text-number in a column can silently understate a total. Use NUMBERVALUE or 
*1 inside formulas, and Text to Columns > Finish for bulk repair. 
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6.  Converting Text Dates with Text to Columns (DMY) 

The problem 

A cell showing 25.05.2026 looks like a date but, because of the dots, Excel stores it as text. Text dates 

cannot be sorted chronologically, cannot be used in ageing or due-date arithmetic, and are ignored by 

date filters and PivotTable date grouping. Real dates are serial numbers; the quick test is 

=ISNUMBER(A2), which returns TRUE only for a genuine date. 

How to convert a whole column 

1. Select the column of text dates. 

2. Data > Text to Columns. 

3. Click Next, then Next again. 

4. In step 3, under Column data format choose Date and select DMY from the dropdown (telling 
Excel the text is Day-Month-Year). 

5. Click Finish. Every cell becomes a true date; apply the display format you want, such as dd-mm-
yyyy, from Format Cells. 

Worked example 

A sales register arrives with invoice dates as 25.05.2026-style text. Your debtors ageing formula, 

which subtracts invoice date from the year-end date, returns errors down the whole column. Selecting 

the date column and running Text to Columns with the DMY setting converts all of it into genuine dates 

in one pass; the ageing column calculates instantly, right down the sheet. 

Choose the letters to match how the source text is written: DMY for 25.05.2026, MDY for 05/25/2026, 

YMD for 2026-05-25. Telling Excel the wrong order silently swaps days and months for dates like 

05.04.2026 - a mistake that no error message will ever reveal. 

Takeaway:  If ISNUMBER() says FALSE, it is not a date - it is a costume. Text to Columns with the 
correct D-M-Y order is the three-click repair. 
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7.  Information Functions - The Auditor's Assertion Tests 

What they are 

The IS family of functions asks a cell one question and answers only TRUE or FALSE: ISNUMBER (is 

this a real number?), ISTEXT (is this text?), ISBLANK (is this truly empty?), ISERROR and ISNA (is 

this an error?), ISFORMULA (is this cell calculated, or was it typed?). They never change data; they 

testify about it - which is precisely an auditor's job. 

Why they matter in audit 

Every problem covered in these notes - text-numbers, text dates, hidden blanks, manual overrides - 

can be detected by an IS function before it does damage. A flag column of =ISTEXT(B2) beside an 

imported amount column instantly maps every defective row. Counting the defects across a whole 

column takes one formula: 

=SUMPRODUCT(--ISTEXT(B2:B1500))     counts amount cells stored as text 

=SUMPRODUCT(--ISBLANK(A2:A1500))    counts missing dates 

ISFORMULA deserves special mention: combined with conditional formatting (rule: 

=NOT(ISFORMULA(B2)) applied over a calculation area), it paints every hardcoded override in a 

model - the same audit test as F5 > Special, but permanent and self-updating. 

Worked example 

Before analysing any client file, build a three-cell quality strip above the data: one SUMPRODUCT 

counting text-numbers in the amount column, one counting blanks in the date column, one counting 

error cells. Conditional formatting turns any non-zero count red. The strip is your data-quality 

certificate: if all three read zero, the data is fit for analysis; if not, the strip tells you exactly what to 

clean first - and it re-audits itself every time the data is refreshed. 

Takeaway:  IS functions return only TRUE or FALSE, but that is exactly what an assertion test 
should do. Build them into every imported file as a permanent data-quality check. 
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8.  Basic PivotTable - From Dump to Summary in 30 Seconds 

What it is 

A PivotTable summarises thousands of rows by any field you choose, with no formulas at all. Drag a 

field to Rows and another to Values, and Excel builds the entire ledger-wise, month-wise or party-wise 

summary for you - and rebuilds it every time you rearrange the fields. 

How to build your first one 

1. Ensure the data is a clean block: one header row, no blank header cells, no merged cells (Topic 
2!), real numbers and real dates (Topics 5 and 6!). 

2. Click any single cell inside the data, then Insert > PivotTable > New Worksheet > OK. 

3. Drag Ledger to the Rows area and Amount to the Values area - it becomes Sum of Amount 
automatically. 

4. To see composition, right-click a value > Show Values As > % of Grand Total. 

5. To audit any figure, double-click it: Excel extracts the exact source rows behind that number to a 
new sheet - instant drill-down evidence. 

6. After the source data changes, right-click inside the pivot and choose Refresh. PivotTables never 
update by themselves - forgetting this is the most common pivot mistake in practice. 

Worked example 

A journal export of several hundred rows needs a ledger-wise summary for the partner. Writing 

SUMIFS per ledger means first building a unique ledger list, then a formula per row - ten minutes of 

careful work. A PivotTable produces the identical summary in under thirty seconds, and double-

clicking the Salaries total instantly produces the twelve underlying entries as supporting detail. 

Takeaway:  Notice the sequence of these notes: a PivotTable is only as reliable as the data feeding 
it. Diagnose (Topics 1, 2, 7), clean (Topics 3, 4, 5, 6), and only then summarise - that order is the 
method. 
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Quick Reference Card 

# Feature / Function Where / How One-line audit use 

1 Go To Special F5 > Special Select every text-number, 
error, blank or hardcode at 
once 

2 Find merged cells Ctrl+F > Format > Alignment > Merge cells > 
Find All 

Locate all merged cells; 
unmerge before analysis 

3 Paste Special 
Operations 

Copy -1 or 100000, Ctrl+Alt+V > Multiply / 
Divide 

Flip signs or convert to lakhs in 
place, no formulas 

4 TRIM + CLEAN + 
SUBSTITUTE 

=TRIM(CLEAN(SUBSTITUTE(A2,CHAR(160)," 
"))) 

Remove every invisible 
character; test with LEN() 

5 Text-number repair NUMBERVALUE(), =A2*1, or Text to Columns 
> Finish 

Make SUM and pivots see the 
numbers 

6 Text-date repair Text to Columns > step 3 > Date > DMY Enable sorting, ageing and 
date arithmetic 

7 IS functions ISNUMBER, ISTEXT, ISBLANK, ISERROR, 
ISFORMULA 

Build a self-updating data-
quality strip 

8 PivotTable Insert > PivotTable; right-click > Refresh Dump to summary in 30 
seconds; double-click to drill 
down 

 

Practice before Session 2: take any raw export from your own office - a Tally day-book, a bank 

statement download, a client TB - and run the full sequence on it: diagnose with F5 and the IS 

functions, clean the text, numbers and dates, then summarize with a PivotTable. Session 2 (Advanced 

Excel) begins from the assumption that this sequence is already comfortable. 


